Continuing: Issue with Badges and Repo Dashboards
Incident Report for Codecov
Resolved
We have deployed fix for the underlying issue. Users should expect to see normal behavior for their badges and repo dashboards
Posted Jan 23, 2024 - 22:24 UTC
Update
A fix for incorrect data in coverage badges and repo overview pages was launched yesterday (January 22nd) and is continuing to be rolled out to all affected repositories through the course of today, January 23rd.
Posted Jan 23, 2024 - 17:59 UTC
Update
We have scheduled a maintenance for this Incident. Maintenance information can be found here: https://status.codecov.com/incidents/dcqgywtr2tpg
Posted Jan 22, 2024 - 21:31 UTC
Identified
The underlying issue has been identified and we are implementing a fix that will be deployed through the course of today, January 22nd.
Posted Jan 22, 2024 - 17:25 UTC
Investigating
We are investigating downstream effects of a weekend incident affecting users' repo coverage badges and their repo overview pages. This incident appears as an incorrect head commit on a given branch.
Posted Jan 22, 2024 - 16:24 UTC
This incident affected: Codecov Frontend.