Issues viewing file contents for private repositories on app.codecov.io
Incident Report for Codecov
Postmortem

This issue resulted from a change in our backend to better support GitHub App installations in our API. The PR tracking the revert and underlying code change can be found here: https://github.com/codecov/codecov-api/pull/355

Posted Jan 24, 2024 - 18:51 UTC

Resolved
We have resolved this issue and will continue to monitor moving forward.
Posted Jan 24, 2024 - 18:40 UTC
Investigating
Currently we are experiencing an issue where project source code is not being fetched properly for private repos in the Codecov UI. This leads to an inability to view line coverage in the UI. We are investigating.
Posted Jan 24, 2024 - 18:26 UTC
This incident affected: Codecov Frontend.