Upload Processing Queue Slowdown

Incident Report for Codecov

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 02:42 UTC

Investigating

We are experiencing a slowdown in upload processing. This issue has been happening intermittently for the past few days. We are currently investigating the issue.
Posted Mar 10, 2026 - 21:44 UTC
This incident affected: Codecov Backend.