Generalized latency issues throughout infrastructure

Incident Report for Codecov

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 21:03 UTC

Monitoring

Some of the our cloud infrastructure provider features are back online.
Posted Jun 12, 2025 - 20:11 UTC

Identified

We have identified the problem as being with our cloud infrastructure provider and have contacted them for further diagnosis. Customer impact is delays in ingestion and intermittent failures for both US customers.
Posted Jun 12, 2025 - 18:38 UTC

Investigating

We are currently investigating latency problems across all of our infrastructure in US regions.
Posted Jun 12, 2025 - 18:37 UTC
This incident affected: Codecov Backend.