Integrity verification on the CLI/Action is failing and blocking uploads to Codecov

Incident Report for Codecov

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 14:33 UTC

Monitoring

The cache has been purged and we are monitoring the issue.
Posted Apr 23, 2026 - 14:15 UTC

Identified

We have identified the issue. There is no security implication for this issue, the releases were re-published and the cache is currently being cleared.
Posted Apr 23, 2026 - 14:15 UTC

Investigating

We are currently investigating the issue.
Posted Apr 23, 2026 - 14:13 UTC