Issue Syncing Repositories and Orgs for New Accounts after GitHub App Installation
Incident Report for Codecov
Resolved
This incident has been resolved. The core issue was a recent was leading to an issue where a database connection could be closed before a new user's group and repo membership could be written to the database. This has been fixed and we've verified that new accounts should be syncing properly now after Github App Installation.

For timeline purposes, this incident would have begun upon introduction of a recent change: Tue, 19 Dec 2023 15:53:34 GMT and was resolved on Thur 21 Dec 2023 21:00:00 GMT.
Posted Dec 21, 2023 - 21:37 UTC
Identified
The issue has been identified and we are working on a fix.
Posted Dec 21, 2023 - 20:42 UTC
Investigating
We're currently investigating an issue where newly added Codecov accounts cannot properly sync their organizations or members after GitHub App Installation.
Posted Dec 21, 2023 - 19:10 UTC
This incident affected: Codecov Backend.