Upload processing is severely delayed

Incident Report for Codecov

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 21:00 UTC

Update

The backlog of tasks is continuing to clear, users affected in the early stages of the incident should expect to see their notifications.
Posted Jul 22, 2026 - 20:37 UTC

Update

The backlog of tasks is clearing at a consistent rate. We will continue monitoring the situation.
Posted Jul 22, 2026 - 20:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 20:05 UTC

Update

The issue has been identified as a an issue with Codecov's redis instance. We are working on a fix.
Posted Jul 22, 2026 - 19:39 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jul 22, 2026 - 19:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 22, 2026 - 18:12 UTC

Update

Changes previously implemented showed some improvement, but the issue remains and needs further investigation. Harness coverage team is currently working on additional investigation and changes.
Posted Jul 22, 2026 - 16:57 UTC

Investigating

We are currently investigating this issue.
Posted Jul 22, 2026 - 16:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 22, 2026 - 15:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 22, 2026 - 15:44 UTC

Investigating

We are currently investigating this issue.
Posted Jul 22, 2026 - 15:02 UTC
This incident affected: Codecov Backend.