Intermittent failures
Incident Report for Codecov
Resolved
A database query began unexpectedly taking large amounts of time to complete. Our SRE team is focused on improving this response time and working closely with our cloud provider to come to a resolution. We have implemented several fixes to mitigate the issues and are continuing to monitor and improve.
Posted Feb 05, 2024 - 17:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 05, 2024 - 16:23 UTC
Investigating
We are currently investigating an issue with our database. High utilization is causing intermittent timeouts and 500s.
Posted Feb 05, 2024 - 12:15 UTC
This incident affected: Codecov Backend.