[GitHub Public Repository Users] Issues retrieving commits and other tasks
Incident Report for Codecov
Resolved
This incident has been resolved.
Posted May 26, 2020 - 18:29 UTC
Monitoring
We have made some fixes on our integration with GitHub, and users should no longer be experiencing issues. We will continue monitoring the situation.
Posted May 20, 2020 - 18:16 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 08, 2020 - 23:07 UTC
Identified
We have identified this issue to be affecting GitHub users on public repositories. This is due to high usage of our API token resulting in a rate limit.

If you are using a team bot (https://docs.codecov.io/docs/team-bot), we **strongly recommend** that you switch to using the app on the GitHub marketplace (https://github.com/marketplace/codecov). We recommend this as a permanent fix, and it should clear up any further issues for you and your repositories.

We will continue to work with GitHub to put in place a more robust solution.
Posted May 08, 2020 - 23:07 UTC
Investigating
GitHub Tokenless Actions users may be experiencing intermittent issues retrieving commits and other tasks. The Codecov team is actively monitoring the situation.
Posted Apr 29, 2020 - 15:45 UTC
This incident affected: Codecov Frontend and Codecov Backend.