Intermittent Timeouts on API Service

Incident Report for Codecov

Resolved

This incident has been resolved. All systems are operational.
Posted Sep 21, 2021 - 18:56 UTC

Monitoring

We have determined root cause for this issue, applied a fix, and are actively monitoring.
Posted Sep 21, 2021 - 18:39 UTC

Investigating

We're currently experiencing intermittent timeout issues on our api service. This may impact user login and various functionality throughout the Codecov application.

We are actively investigating this issue and hope to have a resolution soon.
Posted Sep 21, 2021 - 18:33 UTC
This incident affected: Codecov Frontend and Codecov Backend.